Una community es un mecanismo muy parecido a un TAG, que se le pone a un prefijo de BGP. Las communities se utilizan sobre todo a nivel ISP, y hay communities conocidas que indican si la ruta debe de ser interna, si es exportable...etc.
Cada operador suele tener un documento de communities, al que el resto de ISP deberá acogerse para hacer traffic engineering, pero eso esa es otra historia. En esta vamos a hacer pruebas con comunidades de prueba.
Configuración:
En el lado que añadimos la community, en el otro con hablar BGP con el que agrega la community nos vale.
router bgp xEjemplo:
neighbor x.x.x.x send-community <----necesario ya que por defecto no se envían
neighbor 2.2.2.2 route-map <nombre_route_map> out
route-map <nombre_route_map>permit 10
set community <communities_separadas_espacios>
R3(Anunciador):
router bgp 6
no synchronization
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 5
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 send-community
neighbor 2.2.2.2 route-map COMMOUT out
no auto-summary
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback22
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
!
interface FastEthernet0/1
no switchport
ip address 192.168.2.3 255.255.255.0
ip route 1.1.1.1 255.255.255.255 192.168.2.2
ip route 2.2.2.2 255.255.255.255 192.168.2.2
route-map COMMOUT permit 10
set community 3 33 333
R2:
router bgp 5
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 5
neighbor 1.1.1.1 update-source Loopback0
neighbor 3.3.3.3 remote-as 6
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
no switchport
ip address 192.168.1.2 255.255.255.0
!
interface FastEthernet0/1
no switchport
ip address 192.168.2.2 255.255.255.0
ip route 1.1.1.1 255.255.255.255 192.168.1.1
ip route 3.3.3.3 255.255.255.255 192.168.2.3
R1:
router bgp 5
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 5
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no switchport
ip address 192.168.1.1 255.255.255.0
Verificación:
R2#show ip bgp 22.22.22.22
BGP routing table entry for 22.22.22.22/32, version 6
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Advertised to update-groups:
1
6
3.3.3.3 from 3.3.3.3 (22.22.22.22)
Origin IGP, metric 0, localpref 100, valid, external, best
Community: 3 33 333
R1#show ip bgp 22.22.22.22
BGP routing table entry for 22.22.22.22/32, version 4
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Not advertised to any peer
6
3.3.3.3 from 2.2.2.2 (2.2.2.2)
Origin IGP, metric 0, localpref 100, valid, internal, best
Si os habéis fijado bien podéis observar que R1 no tiene la community en la ruta, es simplemente porque R2 no anuncia communities a R1 :).
Otro día veremos mas BGP que alguno ya me lo ha reclamado.
No hay comentarios:
Publicar un comentario